Version: 1.2.0.5.dev0

stix.utils.parser Module

Classes

class stix.utils.parser.UnsupportedVersionError(message, expected=None, found=None)[source]

Bases: exceptions.Exception

A parsed document is a version unsupported by the parser.

class stix.utils.parser.UnknownVersionError[source]

Bases: exceptions.Exception

A parsed document contains no version information.

stix.utils.parser.UnsupportedRootElement

alias of UnsupportedRootElementError

class stix.utils.parser.EntityParser

Bases: mixbox.parser.EntityParser